php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13784 checkdate(10,31,0) returns false
Submitted: 2001-10-22 03:27 UTC Modified: 2001-10-23 14:09 UTC
From: mike at kristopeit dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.6 OS: windows 2000 pro
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mike at kristopeit dot com
New email:
PHP Version: OS:

 

 [2001-10-22 03:27 UTC] mike at kristopeit dot com
the manual says year can be 0-32767, but giving 0 makes checkdate return false.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-23 06:15 UTC] sniper@php.net
I wonder what manual you're referring to as this page
clearly says that that is not possible:

http://www.php.net/manual/en/function.checkdate.php

--Jani

 [2001-10-23 14:09 UTC] mike at kristopeit dot com
the one at phpbuilder.com

http://www.phpbuilder.com/manual/function.checkdate.php

i would like it to work this way, because many calendar applications have yearly reoccuring events, and it would be nice to have checkdate(month, day, 0) return true if the date could ever be valid (ie checkdate(2,29,0) returns true)

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Feb 17 10:01:25 2020 UTC