php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13776 unable to compile XSLT as shared mod
Submitted: 2001-10-21 08:21 UTC Modified: 2001-10-22 14:56 UTC
From: lenar at city dot ee Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.1.0RC1 OS: Debian
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lenar at city dot ee
New email:
PHP Version: OS:

 

 [2001-10-21 08:21 UTC] lenar at city dot ee
It seems that it isn't possible
to compile php's xslt extension as shared module.

This is bad because until it is possible
distros can't package it separately.

For example right now debian comes with php4-sablot
extension which uses old ext/sablot code.

Since all new development is done with xslt sablot backend
that package is unusable.

In order to make php4-xslt package there must be way to compile it as shared extension.

Configure script seems to understand --enable-xslt=shared
but real linking isn't done.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-21 09:55 UTC] lenar at city dot ee
It seems it works when using additionaly
--enable-shared=xslt
 [2001-10-22 14:56 UTC] sterling@php.net
not a bug, --enable-shared=xslt is correct way.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Nov 26 22:01:23 2020 UTC