php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13743 TTF Fonts
Submitted: 2001-10-19 07:10 UTC Modified: 2001-10-21 14:05 UTC
From: go at maktoob dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Windows 2000 Advanced Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: go at maktoob dot com
New email:
PHP Version: OS:

 

 [2001-10-19 07:10 UTC] go at maktoob dot com
When I used the Image Creation function in the GD Library that have any relation to the TTF fonts the server generate this Error related to PHP.exe

'The instruction at "0x1009fff3" referenced memory at "0x00a50d00". The memory could not be "read".'


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-19 07:15 UTC] mfischer@php.net
Submitted twice, #13743 has slightly more info.

Bogusifying.

- Markus
 [2001-10-19 07:25 UTC] sander@php.net
Let's keep this one open...
 [2001-10-20 13:04 UTC] sander@php.net
Can you provide a sample script?

It might be a problem with GD 2.0, which is still beta. You can try downloading PHP-4.0.5 from http://www.php.net/downloads.php and use php_gd.dll from that distribution (it should work fine with 4.0.6).
 [2001-10-21 01:35 UTC] go at maktoob dot com
the script that I used is almost the same that comes with the PHP documentation ...
the error come when I use the ImageTTFText() function in intensive matter, in other words I called this function about 5-10 times in almost one secound
example of calling 
<img scr="writeText.php?Text=Anything;Fnt=Verdana.ttf;Dest=c:\a1.jpg">

<img scr="writeText.php?Text=Anything2;Fnt=Verdana.ttf;Dest=c:\a2.jpg">

and I wrote this code serveral time in the same page ...
is that should cause the problem ?
 [2001-10-21 09:15 UTC] sander@php.net
I've heard something about GD being not thread safe (at least, not on Windows). Can someone confirm this? If it's not thread safe, that might be the cause of this crash...

Once again, try the php_gd.dll from PHP-4.0.5, which contains a stable version of GD.
 [2001-10-21 09:31 UTC] derick@php.net
GD is not thread safe... so it may crash if PHP is used as ISAPI module.

Derick
 [2001-10-21 13:32 UTC] sander@php.net
Then let's close this bug...
It's in the 4.1 todo anyway:
* Make all extensions thread-safe.
 [2001-10-21 14:05 UTC] derick@php.net


It is not the extension that is not thread-safe, but the GD library itself. This could have been fixed with version 2 though.

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 07:05:52 2022 UTC