php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13677 ImageCopy crashes PHP
Submitted: 2001-10-15 16:57 UTC Modified: 2001-11-11 06:15 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: m dot ullmann at digital-family dot de Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: m dot ullmann at digital-family dot de
New email:
PHP Version: OS:

 

 [2001-10-15 16:57 UTC] m dot ullmann at digital-family dot de
In case you compile GD 2.0.1 with Freetype 2.0.4 and PHP 4.0.6 there seems to be a bug:

If you try to use the function ImageCopy() you get a Segmentation fault

In PHP 4.0.4pl1 it seems to work okay

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-19 07:38 UTC] sander@php.net
Can be a bug in GD 2.0. It's still beta.

Can you (or someone else) try accessing the library directly (not via PHP)?
 [2001-10-21 07:44 UTC] m dot ullmann at digital-family dot de
I just used the test program shipped with the GD package and it works.
 [2001-10-21 08:07 UTC] derick@php.net
Generating a backtrace could really help us, can you make one?
See http://bugs.php.net/bugs-generating-backtrace.php how to make one.

Derick
 [2001-11-11 06:15 UTC] sander@php.net
No feedback. Closing.

Please create a backtrace and reopen this report.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 23:03:43 2022 UTC