php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13674 build/buildcheck.sh fails if automake version strings contains dashes
Submitted: 2001-10-15 15:40 UTC Modified: 2001-10-24 05:59 UTC
From: marco at esiway dot net Assigned:
Status: Closed Package: *Configuration Issues
PHP Version: 4.0.6 OS: RedHat Linux 6.2 + updates
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: marco at esiway dot net
New email:
PHP Version: OS:

 

 [2001-10-15 15:40 UTC] marco at esiway dot net
automake version here is 1.4-p1, and buildcheck fails to
parse it.

build/buildcheck.sh: test: integer expression expected
before -lt

the following patch fixes it (maybe also \. and caps should
be added):

--- php-4.0.6/build/buildcheck.sh.ver	Sat May 12 11:03:58 2001
+++ php-4.0.6/build/buildcheck.sh	Mon Oct 15 21:21:57 2001
@@ -22,7 +22,7 @@
 echo "buildconf: checking installation..."
 
 # autoconf 2.13 or newer
-ac_version=`autoconf --version 2>/dev/null|head -1|sed -e
's/^[^0-9]*//' -e 's/[a-z]* *$//'`
+ac_version=`autoconf --version 2>/dev/null|head -1|sed -e
's/^[^0-9]*//' -e 's/[-a-z][-0-9a-z]* *$//'`
 if test -z "$ac_version"; then
 echo "buildconf: autoconf not found."
 echo "           You need autoconf version 2.13 or newer
installed"
@@ -40,7 +40,7 @@
 fi
 
 # automake 1.4 or newer
-am_version=`automake --version 2>/dev/null|head -1|sed -e
's/^[^0-9]*//' -e 's/[a-z]* *$//'`
+am_version=`automake --version 2>/dev/null|head -1|sed -e
's/^[^0-9]*//' -e 's/[-a-z][-0-9a-z]* *$//'`
 if test "$am_version" = ""; then
 echo "buildconf: automake not found."
 echo "           You need automake version 1.4 or newer
installed"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-20 20:25 UTC] sniper@php.net
What is this automake version? I have stock RH 6.2 automake
installed and it reports the version to be 1.4

--Jani

 [2001-10-24 05:59 UTC] sniper@php.net
This is fixed in CVS long time ago. :)

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Thu May 30 20:01:30 2024 UTC