php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13673 Cannot load extension .dll file
Submitted: 2001-10-15 11:26 UTC Modified: 2001-10-15 11:50 UTC
From: crazycoolonisika at hotmail dot com Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 4.0.4 OS: WindowsMe & WindowsXP
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: crazycoolonisika at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-10-15 11:26 UTC] crazycoolonisika at hotmail dot com
I can load php_gd.dll but cannot load php_domxml.dll.
They are under the same directory.
I have configured the php.ini as follows:

......
;extension=php_db.dll
;extension=php_dba.dll
;extension=php_dbase.dll
extension=php_domxml.dll
;extension=php_dotnet.dll
;extension=php_exif.dll
;extension=php_fdf.dll
;extension=php_filepro.dll
extension=php_gd.dll
;extension=php_gettext.dll
;extension=php_ifx.dll
......

and set the extension_dir as follows:
extension_dir="d:\PHP\"

I am sure the .dll files are under this directory.
But every time I run a .php script through PWS server with PHP as a CGI service,it echo the warning message:

PHP Warning: Unable to load dynamic library 'd:\PHP\php_domxml.dll' 

I need your help,thanks.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-04 13:01 UTC] adrian at amigaglobe dot com
I believe that the problem is with the dll version as an older version of php that the dll works its 46k in size
the latest release has a size of 388kb and won't load for me,
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 04:03:13 2021 UTC