|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13636 configure doesn't find librecode
Submitted: 2001-10-10 23:23 UTC Modified: 2001-11-10 04:31 UTC
From: arne at dome dot net dot tw Assigned:
Status: Not a bug Package: Recode related
PHP Version: 4.0.6 OS: FreeBSD 4.1-RELEASE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: arne at dome dot net dot tw
New email:
PHP Version: OS:


 [2001-10-10 23:23 UTC] arne at dome dot net dot tw
recode is installed from ports in /usr/local/

contents of /usr/local/lib:

contents of /usr/local/include:

./configure --with-recode --with-mysql --with-apache=../apache_1.3.20 --with-gd --enable-track-vars


checking for recode support... yes
configure: error: I cannot link librecode (-L/usr/local/lib -lrecode). Is it installed?


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-11 13:30 UTC]
Check config.log for possible error why the linking 
failed. It's not likely to be recode which fails here.


 [2001-10-11 21:01 UTC] arne at dome dot net dot tw
config.log says:

configure:44401: checking for recode support
configure:44483: gcc -o conftest -g -O2  -DSUPPORT_UTF8  -L/usr/local/lib conftest.c -lgd -lcrypt -lm  -lrecode 1>&5
/usr/local/lib/ undefined reference to `error'
configure: failed program was:
#line 44472 "configure"
#include "confdefs.h"

char *program_name;

int main() {


; return 0; }

what does this mean?
 [2001-10-31 19:31 UTC]
What does 'ldd' output?
What version of recode is this?
How was it compiled?


 [2001-11-01 03:32 UTC] arne at dome dot net dot tw
ldd says:
ldd: Exec format error exit status 1

recode is version 3.6 compiled from the FreeBSD ports directory.

Using recode from the command line works properly.

Meanwhile I updated the OS to FreeBSD 4.4-STABLE.
 [2001-11-02 02:42 UTC]
Seems like there is something wrong with the shared lib.
Try removing those and files
and try to configure PHP again.


 [2001-11-05 20:58 UTC] arne at dome dot net dot tw
Ok, I tried it this way:
I removed the libraries as requested and tried to configure php again -> same error like before

Then I tried to compile recode from source (this time without the ports patches) again, but it failed. Then used the ports directory to recompile recode successfully.
Then I configured php again -> same error.

BTW: the librarues are and, not
I also tried to make a symbolic link to the library with the suffix '2', but no success...
 [2001-11-10 04:31 UTC]
There is something wrong with your install of recode 
libraries and this is not support forum for FreeBSD so
ask them for help on this part. PHP's configure can not
do anything if your system is broken.

 [2003-03-10 04:58 UTC] mbr at freebsd dot org
I have a fix for this. Please look at:

This is a librecode problem, not a PHP problem.

 [2003-06-15 16:46 UTC] php_public at macfreek dot nl
Just letting you know I've got the same problem, with 
Mac OS X (10.2.6), PHP 4.3.2 and Recode 3.6 (3.6-6, 
installed using fink). The error I got in config.log:

ld: Undefined symbols: _error
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 02:01:28 2024 UTC