php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13593 system() & exec() hang
Submitted: 2001-10-07 22:34 UTC Modified: 2002-07-02 01:00 UTC
Votes:20
Avg. Score:4.7 ± 0.7
Reproduced:17 of 17 (100.0%)
Same Version:4 (23.5%)
Same OS:11 (64.7%)
From: jeremy at deadbeef dot com Assigned:
Status: No Feedback Package: PWS related
PHP Version: 4.0CVS-2001-10-07 OS: Windows 98 / PWS
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeremy at deadbeef dot com
New email:
PHP Version: OS:

 

 [2001-10-07 22:34 UTC] jeremy at deadbeef dot com
running any program from system() or exec() causes a console window to pop up brefly, the program runs and then the web server hangs.  

I am running the 4.0.8-dev build from www.php4win.de Oct  4 2001 23:30:20 in CGI mode with personal web server.

To get the web server to work again afterwards, it seems I have to stop the PWS service, ctrl-alt-delete and kill all php processes, and then restart PWS.  Sometimes that doesn't work and I have to reboot.



There are no error messages printed anywhere, it just hangs.  Any program.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-08 21:42 UTC] devinemke at devinemke dot com
I have the exact same problem although I am running PHP 4.1.1 on WinME.  I did not have this problem on PHP 4.0.6.
 [2002-03-20 15:01 UTC] gpike at piocon dot com
I have done extensive tests with exec() and system() using PHP 4.1.2 under Win 98 (and 2000) and experience problems as well.  I attempted to start a console process from PHP and return with a success message.  I have experiemented with several possible solutions purposed under the exec() command reference including putting a "start" in the DOS command and redirecting the output to NUL.  I have also attemted to start a C program that itself started the command in a forked process.  All result in the exec() command hanging until the console is manually stopped.
 [2002-06-01 13:22 UTC] edink@php.net
Could you try PHP 4.2.1 and see if the problem still persists?
 [2002-07-02 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-05-12 06:37 UTC] bhart at insydesw dot com
Hi,

I have downloaded PHP 4.3.1 and loaded it under Win98SE with PSW 4.0.  

I see the already reported problems of not being able to do anything after the system() or exec() calls.  These calls seem to execute ok, but control is never returned to the PHP script, so the remote (client) hangs.

I can Stop PSW, restart it, and get one more try to run the PHP file (from the remote client), after that I have to down Win98SE and start all over.

I tried various things and none ever showed me any execution after the system() or exec() calls.  system() does display data, but nothing from the PHP scripts after the call.

Regards,
-- Bob Hart
 [2003-05-12 06:38 UTC] bhart at insydesw dot com
Oops, obviously that should be PWS 4.0, not PSW 4.0.

Sorry,
-- Bob
 [2003-09-06 08:52 UTC] gwd2 at york dot ac dot uk
I experience the same problem with PHP 4.3.2 under Windows XP
 [2003-11-11 07:53 UTC] g55jw4ec02 at sneakemail dot com
system(), exec(), popen() in PHP 4.3.3 with PWS open a command window, run the program well, close the command window and stuck. [2003-11-11]
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 10:03:34 2021 UTC