php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1357 libphp3.so don't load
Submitted: 1999-04-27 17:13 UTC Modified: 1999-06-24 08:42 UTC
From: bug at nowhere dot no dot place dot for dot bat dot ru Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 3.0.7 OS: BSD/OS 3.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bug at nowhere dot no dot place dot for dot bat dot ru
New email:
PHP Version: OS:

 

 [1999-04-27 17:13 UTC] bug at nowhere dot no dot place dot for dot bat dot ru
BSDI 3.1 is quite specific platform - it has dl-style modules loading,
but don't support true dynamic loading (even, pseudo, static
one exists). After some tweaking the Apache configure I add
support for DSO for BSDI 3.1 - dl was quite enough. Most modules was loaded without the problems, including libperl.so.

But libphp3.so failed to load :( I suspect, that problem is
in unresolved symbols, but due strange nature of BSDI dl I
don't get any unresolved symbols message...

So, how this can be checked and how - solved?



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-06-24 08:42 UTC] sas at cvs dot php dot net
presumely fixed in CVS - pleae check out the upcoming PHP 3.0.10 and report back to php-dev@lists.php.net. Thanks!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jul 13 09:01:23 2020 UTC