|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13487 --with-sablot cannot find reference to iconv
Submitted: 2001-09-28 17:35 UTC Modified: 2001-10-01 23:30 UTC
From: justin at makeig dot com Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.0.6 OS: Mac OS 10.0.4
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
35 - 21 = ?
Subscribe to this entry?

 [2001-09-28 17:35 UTC] justin at makeig dot com
I am trying to build PHP 4.0.6 with the sablot extension on 
Mac OS X. I have been able to successfully build it without 
the --with-sablot flag. However, when I run the 
configuration script with the following flags:

--with apxs=/usr/sbin/apxs

I get the following error:

checking for Sablotron XSL support... yes
checking libexpat dir for Sablotron 0.50... no
checking for Sablotron in default path... found in /usr/
checking for SablotSetEncoding in -lsablot... no
checking for iconv_open in -lc... no
configure: error: iconv not found

I have installed libiconv 1.7 and Sablotron works from the 
command line using sabcmd. Based on the bug report in, I tried altering the 
.m4 files mentioned and running buildconf with no avail on 
a PHP snapshot released on 09/27/2001 (200109272235 from Doing this still gives me the same 


Justin Makeig


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-01 23:30 UTC]
user reported fixed in CVS.

PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 15 20:01:29 2024 UTC