php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13471 Compiler errors
Submitted: 2001-09-28 02:51 UTC Modified: 2001-09-28 04:02 UTC
From: bobhitt at bscnet dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.0.6 OS: Linux 2.4.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bobhitt at bscnet dot com
New email:
PHP Version: OS:

 

 [2001-09-28 02:51 UTC] bobhitt at bscnet dot com
microtime.c: In function `php_if_getrusage':
microtime.c:99: storage size of `usg' isn't known
microtime.c:102: `RUSAGE_SELF' undeclared (first use in this function)
microtime.c:102: (Each undeclared identifier is reported only once
microtime.c:102: for each function it appears in.)
microtime.c:108: `RUSAGE_CHILDREN' undeclared (first use in this function)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-28 03:04 UTC] derick@php.net
It's a FAQ:

http://www.php.net/manual/en/faq.build.php#AEN63063

Not a bug, bogusifying
 [2001-09-28 03:23 UTC] bobhitt at bscnet dot com
 Tried the gcc -E test.c test, no errors, one warning. My libs are pretty up to date. This is the only time I've ever gotten an error installing software.

Any other suggestions?

Bobby

 [2001-09-28 04:02 UTC] bobhitt at bscnet dot com
 Tried the gcc -E test.c test, no errors, one warning. My libs are pretty up to date. This is the only time I've ever gotten an error installing software.

Any other suggestions?

Bobby

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Apr 04 04:01:23 2020 UTC