php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1340 libphp.so: cannot load library
Submitted: 1999-04-21 12:10 UTC Modified: 2000-07-05 02:35 UTC
From: edward at interlook dot com Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 3.0.7 OS: Solaris 2.7 (sparc)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: edward at interlook dot com
New email:
PHP Version: OS:

 

 [1999-04-21 12:10 UTC] edward at interlook dot com
I submitted bug report 1339  Anyway.  With a hint from the PHP bug team (thank you very much) I was able to solve the problem.

if you got this error:

Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1:
                                         /usr/local/apache/bin/httpd: fatal: relocation error: file /usr/local/apache/libexec/libphp3.so: symbol
                                         __udivdi3: referenced symbol not found

then If you link libphp.so with -lgcc under solaris then it works fine... 

is it possible to make the configure script automatically detect this and 
add this LD_FLAG to the compilation process.

I already fixed it on my system, but I am thinking for other people.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-10-17 10:16 UTC] sas at cvs dot php dot net
It's not that simple as it sounds. 
 [2000-07-05 02:35 UTC] rasmus at cvs dot php dot net
This has been addressed now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 27 21:01:25 2020 UTC