php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13325 php_printer.dll causes Access violation in php4ts.dll
Submitted: 2001-09-15 23:46 UTC Modified: 2002-02-04 02:19 UTC
From: ryan at jonasson dot org Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 4.0CVS-2001-09-15 OS: Windows 2000, SP2, all updates
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ryan at jonasson dot org
New email:
PHP Version: OS:

 

 [2001-09-15 23:46 UTC] ryan at jonasson dot org
Command line version of PHP 4.0 CVS, 9-15. Compiled with Visual Studio 6 SP 5 debug version of bind utils, php.exe, and php_printer.dll.  Reproducible with release versions.  When I run php.exe, and manually enter 
<?
   dl('php_printer.dll');
?>

^Z enter

I get:
"The instruction at "0x10113d33" referenced memory at "0x00ebb6c4".  The memory could not be "read". OK to term, Cancel to debug.  when I hit cancel, I am taken to line 222 of printer.c: 
	CALCULATE_REAL_SIZE_AND_CACHE_INDEX(p->size);

The back trace looks like this:
_efree(void * 0x00ebb6c8, char * 0x0110e3d8 `string', unsigned int 158, char * 0x00000000, unsigned int 0) line 222 + 3 bytes
php_printer_shutdown(zend_printer_globals * 0x00df6540) line 158 + 34 bytes
ts_free_thread() line 369 + 34 bytes
php_module_shutdown(void * * * 0x00db1e80) line 1011
main(int 1, char * * 0x00db0070) line 787 + 10 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e97d08()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-16 16:59 UTC] ryan at jonasson dot org
Sorry, the file it errors in is NOT printer.c, it is zend_alloc.c
 [2002-02-04 02:19 UTC] yohgaki@php.net
The version of PHP that this bug was reported in is too old. Please
try to reproduce this bug in the latest version of PHP (available
from http://www.php.net/downloads.php

If you are still able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 27 09:01:26 2020 UTC