php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13318 check compiler failure
Submitted: 2001-09-15 11:02 UTC Modified: 2001-09-15 11:13 UTC
From: ncroiset at vdldiffusion dot com Assigned:
Status: Not a bug Package: *Compile Issues
PHP Version: 4.0.6 OS: linux redhat 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ncroiset at vdldiffusion dot com
New email:
PHP Version: OS:

 

 [2001-09-15 11:02 UTC] ncroiset at vdldiffusion dot com
when I want to do rpm --rebuild php-4.0.6-6.src.rpm from rawhide 1.0.

I obtain this :
Installing php-4.0.6-6.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.95010
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd /usr/src/redhat/BUILD
+ rm -rf php-4.0.6
+ /bin/mkdir -p php-4.0.6
+ cd php-4.0.6
+ /bin/gzip -dc /usr/src/redhat/SOURCES/php-4.0.6.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ pushd php-4.0.6
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6 /usr/src/redhat/BUILD/php-4.0.6
+ echo 'Patch #0 (php-4.0.6-redhat.patch):'
Patch #0 (php-4.0.6-redhat.patch):
+ patch -p1 -b --suffix .redhat -s
+ echo 'Patch #1 (php-4.0.3-required.patch):'
Patch #1 (php-4.0.3-required.patch):
+ patch -p1 -b --suffix .required -s
+ echo 'Patch #2 (php-4.0.4pl1-linkage.patch):'
Patch #2 (php-4.0.4pl1-linkage.patch):
+ patch -p1 -b --suffix .linkage -s
+ echo 'Patch #3 (php-4.0.6-libtool.patch):'
Patch #3 (php-4.0.6-libtool.patch):
+ patch -p1 -b --suffix .libtool -s
+ echo 'Patch #4 (php-4.0.5-db.patch):'
Patch #4 (php-4.0.5-db.patch):
+ patch -p1 -b --suffix .db -s
+ echo 'Patch #5 (php-4.0.5-ext.patch):'
Patch #5 (php-4.0.5-ext.patch):
+ patch -p1 -b --suffix .ext -s
+ cp Zend/LICENSE Zend/ZEND_LICENSE
+ ln -s /usr/include ext/imap/
+ mkdir ext/imap/lib
+ cp -fv /usr/lib/c-client.a ext/imap/lib/libc-client.a
/usr/lib/c-client.a -> ext/imap/lib/libc-client.a
+ ./buildconf
buildconf: checking installation...
buildconf: autoconf version 2.13 (ok)
buildconf: automake version 1.4 (ok)
buildconf: libtool version 1.3.5 (ok)
rebuilding Makefile templates
rebuilding configure
rebuilding main/php_config.h.in
+ popd
/usr/src/redhat/BUILD/php-4.0.6
+ cp -a php-4.0.6 php-4.0.6-cgi
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.99976
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd php-4.0.6
+ krb5libs=-L/usr/kerberos/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
+ ssllibs=-lssl -lcrypto
+ sasllibs=-lsasl -L/usr/kerberos/lib -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
-lssl -lcrypto
+ CFLAGS=-O2 -march=i386 -mcpu=i686 -fPIC
+ export CFLAGS
+ LIBS=-lttf -lfreetype -lpng -ljpeg -lz -lnsl
+ export LIBS
+ REDO_ALL=yes
+ export REDO_ALL
+ EXTENSION_DIR=/usr/lib/php4
+ export EXTENSION_DIR
+ pushd php-4.0.6-cgi
/usr/src/redhat/BUILD/php-4.0.6/php-4.0.6-cgi /usr/src/redhat/BUILD/php-4.0.6
+ compile --enable-force-cgi-redirect
+ CFLAGS=-O2 -march=i386 -mcpu=i686 -fPIC
+ export CFLAGS
+ CXXFLAGS=-O2 -march=i386 -mcpu=i686
+ export CXXFLAGS
+ FFLAGS=-O2 -march=i386 -mcpu=i686
+ export FFLAGS
+ '[' -f configure.in ']'
+ libtoolize --copy --force
Using `AC_PROG_RANLIB' is rendered obsolete by `AM_PROG_LIBTOOL'
+ ./configure i386-redhat-linux --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/
include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --prefix=/u
sr --with-config-file-path=/etc --disable-debug --enable-pic --disable-rpath --enable-inline-optimization --enable-force-cgi-redirect --with-bz2 --with-curl --with-db3 --with-dom --with-exec-dir=/usr/bin --with-gd --with-gdbm --with-gettext --with-jpeg-dir=/usr --with-mm --with-openssl --with-png --with-regex=system --with-ttf --with-zlib --with-layout=GNU --enable-debugger --enable-ftp --enable-magic-quotes --enable-safe-mode --enable-sockets --enable-sysvsem --enable-sysvshm --enable-track-vars --enable-yp --enable-wddx --without-mysql --without-unixOD
BC --without-oracle --without-oci8 --with-pspell --with-xml
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
Updated php_version.h
checking whether to enable maintainer-specific portions of Makefiles... no
checking host system type... i386-redhat-linux-gnu
checking for gawk... gawk
checking for bison... bison -y
checking bison version... 1.28 (ok)
checking for gcc... gcc
checking whether the C compiler (gcc -O2 -march=i386 -mcpu=i686 -fPIC ) works...
 no
configure: error: installation or configuration problem: C compiler cannot create executables.
Bad exit status from /var/tmp/rpm-tmp.99976 (%build)

what is the problem ?

Bye.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-15 11:13 UTC] sniper@php.net
We don't support RPMs. Ask support from Redhat.

--Jani

 [2003-09-09 21:21 UTC] jleafey at utmem dot edu
I have had the same problem with rebuilding the php RPM from the source RPM on Red Hat 8.0 and 9.  Looking at the config.log, it apparently is complaining about not being able to satisfy the switch '-lpng', i.e. it cannot find the libpng.so file.  In looking at the libpng RPM, it appears that is has symlinks for libpng.so.2, libpng.so.3, libpng.so.2.1.0.13 and libpng.so.3.1.2.2, but NOT libpng.so.  I made a symbolic link named libpng.so to the same target as libpng.so.3 and it seemst to work.  This looks like a problem with the png library RPM.  Your mileage may vary!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 03 21:01:23 2020 UTC