php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #133 php3_fopen_url_wrapper() returns unitialized variable fp
Submitted: 1998-03-02 21:10 UTC Modified: 1998-04-18 11:03 UTC
From: jfreeman at wwa dot com Assigned:
Status: Closed Package: Other
PHP Version: 3.0b5 OS: WIN32
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jfreeman at wwa dot com
New email:
PHP Version: OS:

 

 [1998-03-02 21:10 UTC] jfreeman at wwa dot com
The function php3_fopen_url_wrapper()in fopen-wrapper.c does not initialize the fp variable when compiling for WIN32 although it is returned at line 532 (b6).  The cause is the following code

#if !(WIN32|WINNT)
	if ((fp = fdopen (SOCKETD, "r+")) == NULL) {
		free_url(resource);
		return(NULL);
	}

#endif

Why is this code ifdef'd out for WIN32 and where is fp supposed to get initialized?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-04-18 11:03 UTC] rasmus
This code has been rewritten a few times since then.  This bug no longer applies.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 20:05:53 2022 UTC