php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13277 & in query_string are not handled
Submitted: 2001-09-12 20:00 UTC Modified: 2001-09-14 18:14 UTC
From: laurent at bearteam dot org Assigned:
Status: Not a bug Package: Variables related
PHP Version: 4.0.6 OS: Debian GNU/Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: laurent at bearteam dot org
New email:
PHP Version: OS:

 

 [2001-09-12 20:00 UTC] laurent at bearteam dot org
The query_string "a=1&b=2" and "a=1&b=2" should be equivalent, but they are not with php. A workaround is to use arg_separator.input = ";&".

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-14 18:14 UTC] jeroen@php.net
This is wrong.

& is the way to specify & in HTML.

For example:

<a href="script.php?var1=value&amp;var2=othervalue">Click here to continue</a>

But the browser should (according to HTML-specs) request this uri:
script.php?var1=value&var2=othervalue
from internet (i.e., your script)

If the browser doesn't do that, it's a browser bug.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Nov 25 14:01:23 2020 UTC