php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13202 HEAD request problem when use ob_start and ob_end_flush
Submitted: 2001-09-07 17:26 UTC Modified: 2001-09-07 17:34 UTC
From: merrill at missioncriticallinux dot com Assigned:
Status: Closed Package: Output Control
PHP Version: 4.0.4pl1 OS: Redhat Linux 6.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: merrill at missioncriticallinux dot com
New email:
PHP Version: OS:

 

 [2001-09-07 17:26 UTC] merrill at missioncriticallinux dot com
Software:

   Apache/1.3.19 (Unix) PHP/4.0.4pl1 mod_ssl/2.8.2 OpenSSL/0.9.6

and PHP is built as a loadable module for Apache.

'./configure' '--prefix=/var/php' '--with-config-file-path=/var/php' '--enable-track-vars'
                                    '--with-apxs=/var/apache/bin/apxs' '--with-ftp' '--with-xml'
                                    '--with-mcrypt=/var/libmcrypt' '--enable-sigchild'
                                    '--with-oci8=/u01/app/oracle/product/8.1.7' '--with-pgsql=/var/postgresql'
                                    '--with-mysql=/var/mysql'

HEAD requests to PHP pages that have calls to ob_start() and
ob_end_flush() do not work properly.

index.php - *without* ob_start() / ob_end_flush()
-------------------------------------------------
<?
phpinfo();
?>


Here's the response from a HEAD request to that index.php:
----------------------------------------------------------
HTTP/1.1 200 OK
Date: Fri, 07 Sep 2001 21:11:00 GMT
Server: Apache/1.3.19 (Unix) PHP/4.0.4pl1 mod_ssl/2.8.2 OpenSSL/0.9.6
X-Powered-By: PHP/4.0.4pl1
Connection: close
Content-Type: text/html

Connection closed by foreign host.

===========================================================================

index.php - *with* ob_start() / ob_end_flush()
----------------------------------------------
<?
ob_start();
phpinfo();
ob_end_flush();
?>


Here's the response from a HEAD request to that index.php:
----------------------------------------------------------

Connection closed by foreign host.



Is this a bug with PHP 4.0.4pl1?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-07 17:34 UTC] rasmus@php.net
This is fixed in later versions.  Not quite sure which version fixed it though.  Try 4.0.6.  Definitely fixed in 4.0.7.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Dec 09 12:05:45 2021 UTC