php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13156 php segfaults on imap_sort
Submitted: 2001-09-05 17:40 UTC Modified: 2002-06-24 23:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: janmailing at gmx dot de Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0CVS-2001-09-05 OS: Linux 2.2.16
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: janmailing at gmx dot de
New email:
PHP Version: OS:

 

 [2001-09-05 17:40 UTC] janmailing at gmx dot de
When sorting big folders (>4500 msgs) php crashes with a segfault and produces this bt:

Program received signal SIGSEGV, Segmentation fault.
0x4010d55c in realloc () at malloc.c:3135
3135    malloc.c: No such file or directory.
(gdb) bt
#0  0x4010d55c in realloc () at malloc.c:3135
#1  0x81de067 in fs_resize (block=0x8559b98, size=2048) at fs_unix.c:46
#2  0x81ef766 in imap_sort (stream=0x84f8e60, charset=0x0, spg=0x851da98, pgm=0x83ca1f0, flags=1) at imap4r1.c:1629
#3  0x81d37d6 in mail_sort (stream=0x84f8e60, charset=0x0, spg=0x851da98, pgm=0x83ca1f0, flags=1) at mail.c:3557
#4  0x80aa5b9 in zif_imap_sort (ht=5, return_value=0x8525594, this_ptr=0x0, return_value_used=1) at php_imap.c:2532
#5  0x817f0ba in execute (op_array=0x8445090) at ./zend_execute.c:1590
#6  0x817f298 in execute (op_array=0x83c6874) at ./zend_execute.c:1630
#7  0x815a274 in zend_execute_scripts (type=8, file_count=3) at zend.c:807
#8  0x80893cf in php_execute_script (primary_file=0xbffff3c8) at main.c:1310
#9  0x816620c in apache_php_module_main (r=0x831bdac, display_source_mode=0) at sapi_apache.c:90
#10 0x808589e in send_php ()
#11 0x8085906 in send_parsed_php ()
#12 0x8189aa9 in ap_invoke_handler ()
#13 0x819f01f in process_request_internal ()
#14 0x819f092 in ap_process_request ()
#15 0x8195c96 in child_main ()
#16 0x8195e55 in make_child ()
#17 0x8195fd6 in startup_children ()
#18 0x819665c in standalone_main ()
#19 0x8196e8c in main ()
#20 0x400d3a8e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93

This is my config line:

'./configure' \
'--with-mysql=/usr' \
'--with-imap=/home/jan/software/imap-2001' \
'--with-zlib=yes' \
'--with-xml' \
'--with-mcal=/usr' \
'--with-ftp' \
'--with-config-file-path=/etc/httpd' \
'--with-apache=/home/jan/software/apache_1.3.20' \
'--enable-inline-optimization' \
'--enable-track-vars' \
'--enable-magic-quotes' \
'--enable-bcmath' \
'--enable-calendar' \
'--enable-ftp' \
'--enable-memory-limit' \
'--enable-wddx' \
'--enable-debug' \
'--with-gettext' \
'i386-suse-linux-gnu' \

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-05 17:41 UTC] janmailing at gmx dot de
This also happened with earlier version at least since the 4.0.7-dev tree.
 [2002-06-24 23:11 UTC] kalowsky@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 04:03:38 2021 UTC