php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13154 ODBC query to Openingres 2.0 fail with scs_p_GetTblAttribs: DRV_DDTables failed
Submitted: 2001-09-05 14:57 UTC Modified: 2002-08-12 22:33 UTC
From: andre dot felipe at embrapa dot br Assigned: ahill (profile)
Status: Not a bug Package: ODBC related
PHP Version: 4.0.6 OS: Solaris 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andre dot felipe at embrapa dot br
New email:
PHP Version: OS:

 

 [2001-09-05 14:57 UTC] andre dot felipe at embrapa dot br
No queries can be made with PHP 4 and Openlink ODBC to access OpenIngres.

Test program:
<? echo " Teste de ODBC<P>" ;
$odbc = odbc_connect("Desenv" , "notes", "notes", SQL_CUR_USE_IF_NEEDED   );
echo " ODBC_CONNECT return code: $odbc ";

$query = "select matrica from srhtb002";
$queryprep = odbc_prepare ($odbc, $query);   // This produces the error.
$result = odbc_execute($queryprep );
print "ok. result = $result";

$nextrow = odbc_fetch_row($result, 1);

if (! $nextrow ) {
 print "Nco achou nada...<br>";
    }
else {
    print odbc_result($result , 1 );
    print "<br>";
    print odbc_result($result , 2 );
}
?>            

The configure line is:
./configure  --enable-track-vars --with-yp --with-apxs --with-oci8 --with-iodbc=/software/openlink/odbcsdk

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-07 12:25 UTC] kalowsky@php.net
Assigning this to Ahill as he knows the OpenLink software best.
 [2001-12-07 13:11 UTC] ahill@php.net
We've not had any problems with your configuration - are you getting an error message?

Best regards,
Andrew Hill

 [2001-12-28 06:10 UTC] lobbin@php.net
No feedback. Closing.
 [2002-01-02 07:27 UTC] andre dot felipe at embrapa dot br
Hello Lobbin,
I didn't give any feedback just because I have no password to enter the system and issue my opinions.
The problem is still there, I have a case opened in OpenLink SW for a long time for this matter and
have sent to them every log
they asked to try to help in solving the problem.
This problem seems to be with Openlink driver, or else with the form that PHP 4.x uses it.
I'm sure its a compatibility problem between the two.

Happy new year,
Andr? Felipe
 [2002-06-09 16:17 UTC] kalowsky@php.net
Doing two things:

1) comment: I use OpenLink for local testing here and find that the odbc_prepare works fine with PostgreSQL ODBC, MS Access, and the Virtuoso DB.

2) Marking the status as assigned, as it's apparently been assigned to ahill.  Let the email annoyances begin!
 [2002-08-12 22:33 UTC] kalowsky@php.net
Actually I'm going to mark this as bogus, as it's not really a bug with PHP, more with the OpenLink driver itself from some minor investigation.  Andrew Hill would be a good contact point to help resolve this...

minor investigation = it works on my iODBC to Virtuoso, PostgresODBC, and MSAccess.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Jan 20 05:01:25 2020 UTC