php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13148 Can't get data out of a ADO database with ADODB when using 4.07RC1
Submitted: 2001-09-05 09:13 UTC Modified: 2001-09-07 06:03 UTC
From: peterd at telephonetics dot co dot uk Assigned:
Status: Closed Package: *Database Functions
PHP Version: 4.0.6 OS: Windows NT 4 Server
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: peterd at telephonetics dot co dot uk
New email:
PHP Version: OS:

 

 [2001-09-05 09:13 UTC] peterd at telephonetics dot co dot uk
Hi,

I've been using ADODB with the default windows build of PHP v4.06 to retrieve data from an Access database using ADO.

Everything worked fine under PHP 4.06 but when trying out 4.07RC1 no data is returned only empty recordsets.  It still works for odbc databases just not for ADO and a few others.

I reported this as a bug to John Lim at his ADODB bug report site but he said he hasn't tested 4.07 yet and to report it here.

Here's a simple script that under PHP 4.06 works fine but no data is returned at all under PHP 4.07RC1.

Note: It uses an access database set up with a system DSN called testDB and the database has one table (Table1) with two fields in it.

<?php
include('tohtml.inc.php');
include('adodb.inc.php');

$szSQL = "SELECT * FROM Table1";

$objConn = &ADONewConnection('ado');
$objConn->Connect("testDB");
$objRS = $objConn->Execute($szSQL);

if (!$objRS->EOF)
	echo "got some data<BR>";
else
	echo "didn't get any data<BR>";

rs2html($objRS, 'border=2 cellpadding=3', array('Number','Test Text'));

// close the database connections
$objRS->Close();
$objConn->Close();

?>

Under PHP 4.06 you get: "got some data" and then the HTML table output from rs2html.

Under PHP 4.07RC1 you just get: "didn't get any data"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-07 06:02 UTC] peterd at telephonetics dot co dot uk
I've just tried out the same thing with the new 4.07 release candidate 2 build and it works fine now.

Whatever the problem was it's been fixed.  Thankyou

The improvement in speed over 4.06 is also amazing!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 24 09:01:24 2020 UTC