php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13140 setting multiple include_path for php that run on windows server
Submitted: 2001-09-04 15:12 UTC Modified: 2001-09-04 15:31 UTC
From: rivaisalim at hotmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.4 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: rivaisalim at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-09-04 15:12 UTC] rivaisalim at hotmail dot com
It looks like there is a bug for setting multiple include_path for php that run at windows server.

For php that runs at non windows server:
you can set
include_path	= .:/www/includes:path3
and when ever we use include it will always look for all the path starting from . and /www/includes and so on. If you specify your own path at include statement, eg: include "/test/test.php";
it will be found at "./test/test.php".

include_path	= c:\www\root\includes
single path works find with windows server.
I have problem when trying to set multiple path. 
As the php.ini comment:
include_path	= .;c:\www\root\includes
won't works (may be anything after ; are comments!)

However I can go around this by specify 1 include path and always use "." whenever I use include statement.
eg include "./test/test.php";

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-04 15:31 UTC] sander@php.net
Not a bug. Correct way to specify multiple paths in the INI-file on Windows:
include_path = ".;c:\php\includes"
and on Unix
include_path = ".:/php/includes"

Directly taken from php.ini...
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 04:01:23 2020 UTC