php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13076 Freetype 2 not enabled
Submitted: 2001-08-31 06:21 UTC Modified: 2001-09-04 19:58 UTC
From: florent at chantret dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: FreeeBSD 4.3 and Mandrake 7.2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: florent at chantret dot com
New email:
PHP Version: OS:

 

 [2001-08-31 06:21 UTC] florent at chantret dot com
I've tried on two systems to build PHP with GD and Freetype 2.

It doesn't work. PHP always report in the configuration phase that Freetype 2 support is not enabled in GD. But it is enabled cause I can launch the gdtestft !!!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-31 06:44 UTC] sander@php.net
Can you post your configure-line of PHP and of GD?
 [2001-08-31 07:04 UTC] florent at chantret dot com
In fact, I use the ports from FreeBSD. The Makefile.inc looks like this :

LIB_DEPENDS+=   gd.2:${PORTSDIR}/graphics/gd
LIB_DEPENDS+=   freetype.7:${PORTSDIR}/print/freetype2
LIB_DEPENDS+=   png.4:${PORTSDIR}/graphics/png
LIB_DEPENDS+=   jpeg.9:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--with-gd=${PREFIX} \
                --with-freetype-dir=${PREFIX} \
                --with-jpeg-dir=${PREFIX} \
                --with-png-dir=${PREFIX}
CONFIGURE_ARGS+=--with-zlib

During the configuration phase, I can see the following message :

"Checking whether to include freetype text support in GD... no" (or something like this :o) )

and few lines bellow :

"Checking for Freetype(2)... found"

phpinfo() give me the following :

GD Support enabled 
GD Version 1.6.2 or higher 
FreeType Support enabled 
FreeType Linkage with freetype 
JPG Support enabled 
PNG Support enabled 
WBMP Support enabled 

And of course the ImageTTFText doesn't work telling me that libgd is compiled without the support for freetype.

Not true cause I can launch the exe example gdtestft.

So I've tried to add the following in the Makefile.inc but I still have the "Checking whether to include freetype text support in GD... no" :

--enable-freetype-4bit-antialias-hack

or

--enable-gd-native-ttf

The problem is on a FreeBSD 4.3, with PHP 4.0.6, GD 1.8.4 and Freetype 2.0.4 but I've noticed the same problem on other configuration like a Mandrake 7.2, running PHP 4.0.5.

HHHHEEEELLLLPPPPPPP :o)

 [2001-08-31 07:07 UTC] florent at chantret dot com
In fact, I use the ports from FreeBSD. The Makefile.inc looks like this :

LIB_DEPENDS+=   gd.2:${PORTSDIR}/graphics/gd
LIB_DEPENDS+=   freetype.7:${PORTSDIR}/print/freetype2
LIB_DEPENDS+=   png.4:${PORTSDIR}/graphics/png
LIB_DEPENDS+=   jpeg.9:${PORTSDIR}/graphics/jpeg
CONFIGURE_ARGS+=--with-gd=${PREFIX} \
                --with-freetype-dir=${PREFIX} \
                --with-jpeg-dir=${PREFIX} \
                --with-png-dir=${PREFIX}
CONFIGURE_ARGS+=--with-zlib

During the configuration phase, I can see the following message :

"Checking whether to include freetype text support in GD... no" (or something like this :o) )

and few lines bellow :

"Checking for Freetype(2)... found"

phpinfo() give me the following :

GD Support enabled 
GD Version 1.6.2 or higher 
FreeType Support enabled 
FreeType Linkage with freetype 
JPG Support enabled 
PNG Support enabled 
WBMP Support enabled 

And of course the ImageTTFText doesn't work telling me that libgd is compiled without the support for freetype.

Not true cause I can launch the exe example gdtestft.

So I've tried to add the following in the Makefile.inc but I still have the "Checking whether to include freetype text support in GD... no" :

--enable-freetype-4bit-antialias-hack

or

--enable-gd-native-ttf

The problem is on a FreeBSD 4.3, with PHP 4.0.6, GD 1.8.4 and Freetype 2.0.4 but I've noticed the same problem on other configuration like a Mandrake 7.2, running PHP 4.0.5.

HHHHEEEELLLLPPPPPPP :o)

 [2001-09-04 08:43 UTC] florent at chantret dot com
Duplicate : see bug 12065
 [2001-09-04 19:58 UTC] sniper@php.net
The report this is duplicate of is closed, so should this be
then too..

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 03:05:52 2022 UTC