php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13064 Apache 1.3.9 won't load libphp4.so when sablot built with expat
Submitted: 2001-08-30 12:20 UTC Modified: 2001-08-30 15:51 UTC
From: abantly at statsoft dot com Assigned:
Status: Not a bug Package: Sablotron XSL
PHP Version: 4.0.6 OS: Red Hat 7.0 on Alpha
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: abantly at statsoft dot com
New email:
PHP Version: OS:

 

 [2001-08-30 12:20 UTC] abantly at statsoft dot com
./configure --with-apxs=/usr/local/apache/bin/apxs --with-sablot

Also, expat and sablot were dl'd from sourceforge; configured and installed with ./configure ..., so that i could use sablot as a DSO.

/usr/local/apache/bin/apachectl start

The error message is:
Cannot load /usr/local/apache/libexec/libphp4.so into server: libexpat.so.0: cannot open shared object file: No such file or directory.

PHP 4.0.6 was working fine in Apache 1.3.9 until I re-installed php with sablot.  Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-30 15:51 UTC] sniper@php.net
This just indicates that you haven't followed installation
instructions. ie. Your /etc/ld.so.conf doesn't have the
correct entry in it and you haven't run /sbin/ldconfig

Ask further support questions on the mailin lists:

http://www.php.net/support.php

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Sep 20 22:01:27 2019 UTC