php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #13016 what is the output from preg_replace("/a/", '$1','a')
Submitted: 2001-08-29 02:50 UTC Modified: 2001-08-29 02:59 UTC
From: dour at ctc dot org dot cn Assigned:
Status: Closed Package: *Regular Expressions
PHP Version: 4.0.6 OS: FreeBSD 4.3-STABLE
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: dour at ctc dot org dot cn
New email:
PHP Version: OS:

 

 [2001-08-29 02:50 UTC] dour at ctc dot org dot cn
What is the output from exit(preg_replace("/a/", '$1','a'));
'$1' or ''?
I want it is '$1',but it is '';
BUG?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-29 02:59 UTC] mathieu@php.net
No, not a bug - you didn't group anything so $1 would be empty.
Please consult a support forum.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Dec 05 18:03:43 2022 UTC