php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #130 problem with magic quotes
Submitted: 1998-03-02 13:30 UTC Modified: 1998-03-05 11:45 UTC
From: pfig at co dot telenet dot pt Assigned:
Status: Closed Package: MySQL related
PHP Version: 3.0b5 OS: solaris 2.5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: pfig at co dot telenet dot pt
New email:
PHP Version: OS:

 

 [1998-03-02 13:30 UTC] pfig at co dot telenet dot pt
i have defined MAGIC_QUOTES when compiling php. the problem
i'm experiencing is that when i enter some data containing
' in mysql, it gets properly quoted (\'), but when i fetch
that data it gets quoted again and shows up as \\\'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-05 11:45 UTC] zeev
No response from the user, unable to reproduce the problem.
The problem was most probably due to an errorenous script, that passes escaped
contents in between pages, thus getting them to be escaped more than once.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Jul 21 10:01:26 2019 UTC