php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12992 php ignores Accept: text/vnd.wap.wml
Submitted: 2001-08-28 03:02 UTC Modified: 2002-08-20 08:32 UTC
From: tf at tfromm dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.6 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tf at tfromm dot com
New email:
PHP Version: OS:

 

 [2001-08-28 03:02 UTC] tf at tfromm dot com
when 
Accept: text/vnd.wap.wml
or other type is accepted and the .php site has only text/html , 
then an error should returned like:

406 Not Acceptable

like apache does.

for example:

tf@defiant:~/foobar > telnet stargazer 80
Trying 192.168.0.6...
Connected to stargazer.
Escape character is '^]'.
GET / HTTP/1.0
User-Agent: SMS
Accept: text/vnd.wap.wml
 
HTTP/1.1 406 Not Acceptable



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-20 08:32 UTC] edink@php.net
This is not a bug. PHP lets application programmer decide what to the with the accept headers.

See http://www.php.net/manual/en/function.getallheaders.php
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 20:01:29 2024 UTC