php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12990 Problems with system/exec after upgrade
Submitted: 2001-08-28 02:42 UTC Modified: 2001-10-02 19:15 UTC
From: daniel at eldata dot se Assigned:
Status: Closed Package: Program Execution
PHP Version: 4.0.6 OS: Redhat 7.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: daniel at eldata dot se
New email:
PHP Version: OS:

 

 [2001-08-28 02:42 UTC] daniel at eldata dot se
Hello

Then we made a upgrade fr?n Redhat 7.0 and PHP 404 this syntax stopped to work. It keep tellning me that the command failed. 


      if(system($cmd))
        $Msg.="The command was successful.";
      else
        $Msg.="Nope it didnt worked.";

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-28 04:51 UTC] lyric@php.net
What does $cmd actually return?  system() returns the last line of output from the command, which will evaluate to false for things like "0" or "".  Try using exec() and printing the output from there if you are unsure. 
 [2001-08-28 05:53 UTC] lyric@php.net
User replied:
---
The problem is that I used exec() before the update and it worked fine. I have another script that does the same thing that script doesnt work anymore either.

No other employee at my work have changed the file so the update is the only thing I can think of to blame.
---

Plenty of things changed, including a lot of stuff with Redhat 7.0 -> 7.1.  Did you recompile PHP after the upgrade?

Again, what does $cmd actually return?  Also, try :
   $line = system($cmd,$retvar);
   $msg = "system($cmd) --> $retvar, $line";
and tell me what it says
 [2001-10-02 19:15 UTC] sniper@php.net
No feedback and not enough information.

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 12:01:27 2024 UTC