php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12918 end_error: referenced symbol not found, while loading a php extension module
Submitted: 2001-08-23 07:07 UTC Modified: 2001-08-24 02:35 UTC
From: x at zsch dot de Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 4.0.4pl1 OS: Solaris
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: x at zsch dot de
New email:
PHP Version: OS:

 

 [2001-08-23 07:07 UTC] x at zsch dot de
using dl() within php and apache, I get the following error
message:

Warning: Unable to load dynamic library 'libhostphp.so'
- ld.so.1: .../bin/httpd: fatal: relocation error: file libhostphp.so:
symbol zend_error: referenced symbol not found in .../test.php


The symbol zend_error (among others) should be delivered by php/apache, that
is program file httpd.

The same module (recompiled) works on linux.
Does anyone know, how to get this symbol?

Thank You very much
Joacim Zschimmer

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-23 08:30 UTC] sniper@php.net
Have you tried PHP 4.0.6?
And what actually IS libhostphp.so ??

--Jani

 [2001-08-24 02:35 UTC] sniper@php.net
Most likely the problem is in your self written extension.
Not PHP bug.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 09:01:23 2020 UTC