php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12869 drawing small PNGs to large JPEG
Submitted: 2001-08-21 04:26 UTC Modified: 2001-08-22 04:11 UTC
From: O dot Guertler at gmx dot net Assigned:
Status: Not a bug Package: GD related
PHP Version: 4.0.6 OS: Win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: O dot Guertler at gmx dot net
New email:
PHP Version: OS:

 

 [2001-08-21 04:26 UTC] O dot Guertler at gmx dot net
I use php for a map tool, that draws partially transparent small PNG icons with 2, 4 or 8 colors to a large JPEG and the sends it to browser. It worked fine with php 4.0.5 but on 4.0.6 only single colored rectangles are painted, instead of the PNGs.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-21 05:24 UTC] sniper@php.net
Is here anything you might be doing too:

http://www.php.net/bugs.php?id=11976&edit=1

??


 [2001-08-22 03:23 UTC] wez@php.net
It's a GD 2.0.1 bug with transparent palette based PNGs.
I submitted a patch to boutell.com ages ago, but he has not
released an update since then.
As a workaround, try using true-color pngs, or step back
to an earlier GD dll.

--Wez.
 [2001-08-22 04:11 UTC] sniper@php.net
Not a bug in PHP.

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC