php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12855 ereg_replace not working
Submitted: 2001-08-20 05:17 UTC Modified: 2001-08-31 06:38 UTC
From: simonegrassi at yahoo dot com Assigned:
Status: Closed Package: Regexps related
PHP Version: 4.0.6 OS: Linux RedHat 7.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: simonegrassi at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-08-20 05:17 UTC] simonegrassi at yahoo dot com
$nm = ereg_replace( " ", " ", $nm );

I'am debugging a script where it doesn't work!

$nm has been passed with in-line parameters (read-only ???),
but it does not work also in the following way:

// $nm is "test with blank.pdf"

$newVar = $nm;
$tryIt = ereg_replace( " ", " ", $newVar );

// $tryIt is always "test with blank.pdf"

in another script it works (???) with the same simple substitution,

many thanks,
Simone Grassi.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-31 06:38 UTC] sander@php.net
Unable to reproduce.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 13 21:01:24 2019 UTC