php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12849 404 errors related to PHP return internal server error
Submitted: 2001-08-19 20:03 UTC Modified: 2001-10-21 00:34 UTC
From: saturn at dotslashsaturn dot org Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.6 OS: Windows ME (kernel 4.9.3000)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: saturn at dotslashsaturn dot org
New email:
PHP Version: OS:

 

 [2001-08-19 20:03 UTC] saturn at dotslashsaturn dot org
normally, 404 errors are something like

404
the file you requested, /blah.txt, cant be found
etc.. blah

however, when a 404 occurs with a PHP file that doesnt exist, my apache server returns a 500 internal server error, and this is in the error log:

[Sun Aug 19 20:00:42 2001] [error] [client 65.24.26.140] Premature end of script headers: c:/php/php.exe


I couldn't find any "fix" for this, so I'm assuming its some sort of bug, or I've (somehow) managed to mess up my server configuration worse than anyone else ever has.

any help with this is greatly appreciated.

thanks,
-andrew saturn

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-21 00:34 UTC] sniper@php.net
Please ask support questions on the mailing lists:

http://www.php.net/support.php

(not a bug)

 [2002-05-15 10:07 UTC] php at savignano dot net
I don't see why this is not recognized as a bug?

On the other side, I did find many complaints about it in the newsgroups. So why not change it?
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Tue May 28 01:01:31 2024 UTC