php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12838 Cannot load php_fdf.dll
Submitted: 2001-08-19 07:12 UTC Modified: 2001-08-19 17:44 UTC
From: mail at t-rogall dot de Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.6 OS: Windows NT SP6
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: mail at t-rogall dot de
New email:
PHP Version: OS:

 

 [2001-08-19 07:12 UTC] mail at t-rogall dot de
I'm using PHP 4.0.6 as CGI on IIS4 and I want to use the fdf_*-functions. 

But when I'm activating "extension=php_fdf.dll" in the php.ini I'm getting the system-error "Unable to load dynamic library c:/php4/extensions/php_fdf.dll - the module was not found". But this file definitely exists.

I'm pretty sure that my configuration is OK since the extension_dir is correctly set and other extensions (f.e. php_gd.lib or php_mssql.dll) work properly.

Even activating the (perhaps required?) other pdf-extensions php_cpdf.dll and php_pdf.dll does not solve the problem.

Just for testing purposes I activated some other dll's:
extension=php_db.dll
extension=php_dba.dll
extension=php_dbase.dll
extension=php_domxml.dll
extension=php_dotnet.dll
extension=php_exif.dll
extension=php_fdf.dll
extension=php_filepro.dll
extension=php_gd.dll

I found that (from these) only php_domxml.dll and php_fdf.dll cannot be loaded. 

BTW: Activating *all* extensions leads to approx. 10 error-messages.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-19 14:48 UTC] sniper@php.net
You have failed to read both install.txt and the manual
page for installing extensions for Windows systems.

There you would have find this:

http://www.php.net/manual/en/install-windows.php#install.windows.extensions

"Note: Some of these extensions need extra dlls to work. 
Couple of them can be found in the distribution package,
in the 'dlls' folder but some, e.g. Oracle (php_oci8.dll) 
require dlls which are not bundled with the distribution"

 [2001-08-19 17:44 UTC] mail at t-rogall dot de
Hello sniper (?),

thank you very much for your really quick response, esp. on a Sunday! It really seems that I was too lazy reading the online-documentation and I had a recent version on my PC ... 

I'm always very happy to work with PHP - it's really the best choice for programmers!

Greetings from germany - Thomas
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Mar 28 06:03:37 2023 UTC