php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12837 Problem with a variable in URL
Submitted: 2001-08-19 07:00 UTC Modified: 2001-08-19 07:48 UTC
From: Lorenz dot gross at gmx dot de Assigned:
Status: Not a bug Package: Output Control
PHP Version: 4.0.6 OS: Windows 2000 Professional
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Lorenz dot gross at gmx dot de
New email:
PHP Version: OS:

 

 [2001-08-19 07:00 UTC] Lorenz dot gross at gmx dot de
As follows I submit a variable if by URL:
http://server/list.php?name=i'm a bug

I then get the variable distributed as follows:

i\'m a bug

This goes if I want for these to replace BACKSLASH only with this function:
str_replace

ereg_replace has problems

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-19 07:48 UTC] mfischer@php.net
Certainly not a bug; ask on php-general@lists.php.net for support questions.

- Markus
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 08:01:27 2019 UTC