php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12828 error_reporting in apache conf is broken
Submitted: 2001-08-18 17:10 UTC Modified: 2001-10-20 19:43 UTC
From: SL at sentientnetware dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: SL at sentientnetware dot com
New email:
PHP Version: OS:

 

 [2001-08-18 17:10 UTC] SL at sentientnetware dot com
php_value error_reporting E_ALL does not work in the apache httpd.conf.  In fact, no matter what the setting...all errors are not shown and not logged.

When I look at phpinfo(), the global error_reporting level is represented by a number...like 2039 (which is E_ALL & ~E_NOTICE)

But the local error_reporting just says E_ALL.  I'm thiking when set from the conf, php doesn't change E_ALL to the proper bit-value.

I just tried:
php_value error_reporting 2047 (the value of E_ALL) in the .conf and it works!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-20 19:43 UTC] sniper@php.net
This is mentioned in the manual:

http://www.php.net/manual/en/configuration.php

Not a bug.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 21:01:23 2020 UTC