php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12778 Could not find/open font
Submitted: 2001-08-15 19:17 UTC Modified: 2001-08-15 23:52 UTC
From: tim at motionpixels dot com Assigned:
Status: Not a bug Package: GD related
PHP Version: 4.0.6 OS: Linux Redhat 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tim at motionpixels dot com
New email:
PHP Version: OS:

 

 [2001-08-15 19:17 UTC] tim at motionpixels dot com
I don't know whether it's just me but i keep getting this 
message when trying to use the 'ImageTTFText' function. I 
saw in another bug report that php-4.0.6 was the cause and 
that it was fixed in the CVS... i've tryed out 
php-4.0.7-dev but still no joy... everything seems to go 
fine during the compilation process... and phpinfo 
displays:

GD Support	- enabled
GD Version	- 2.0 or higher
FreeType Support	- enabled
FreeType Linkage	- with freetype
JPG Support	- enabled
PNG Support	- enabled
WBMP Support	- enabled

i'm using apache_1.3.20, freetype-2.0.4 & gd-2.0.1, and 
have tried it both php-4.0.6 & php-4.0.7-dev using the 
following configure command:

./configure --with-apache=../apache_1.3.20 
--with-mysql=/usr/local/mysql --with-gd --with-ming 
--enable-gd-native-ttf 
--with-freetype-dir=/usr/local/include/freetype2 
--with-png-dir --with-jpeg-dir --with-zlib-dir 
--enable-track-vars --enable-trans-sid

are you sure the CVS is ok?

cheers

tim

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-15 23:52 UTC] sniper@php.net
RTFM: 

You have to pass the _full_ path to the font file.

--Jani

 [2004-07-18 08:20 UTC] ssddgreg at email dot si
Hi!

I can not generate images in PHP with TTF fonts - my phpinfo file says the following:

GD Support  enabled  
GD Version  1.6.2 or higher  
FreeType Support  enabled  
FreeType Linkage  with freetype  
GIF Read Support  enabled  
JPG Support  enabled  
PNG Support  enabled  
WBMP Support  enabled  


What is "FreeType Linkage  with freetype" - can I convert my TTF font to "freetype"?

Please help
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC