php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12773 gethostbyname with timeout
Submitted: 2001-08-15 16:46 UTC Modified: 2001-11-04 16:09 UTC
From: richard at phase dot org Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.6 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: richard at phase dot org
New email:
PHP Version: OS:

 

 [2001-08-15 16:46 UTC] richard at phase dot org
gethostbyname can appear to hang indefinitely; I assume that this happens if the expected DNS responses are not forthcoming. Unfortunately if this happens in a webpage it can cause a cache or browser timeout, losing the entire page. A variant of this function with an optional timeout parameter would solve this problem.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-04 16:09 UTC] sander@php.net
Dupe of 12802, which has more info so I'm closing this one.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 13 05:01:26 2019 UTC