php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12764 php4isapi.dll module clashes with exchange server
Submitted: 2001-08-15 07:52 UTC Modified: 2002-06-18 18:45 UTC
From: d99flopp at dtek dot chalmers dot se Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.6 OS: WIN2000 5.00.2195 service pac 2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: d99flopp at dtek dot chalmers dot se
New email:
PHP Version: OS:

 

 [2001-08-15 07:52 UTC] d99flopp at dtek dot chalmers dot se
Runing an IIS server, it seams like the php4isapi.dll module interfears with the Exchange server on the same machine. PHP also seams to encounter several acces-violations randomly during runtime.


The errorlogg on the machine shows (from startup): 
"A fatal error occurred while creating an SSL server credential"
The errorlogg on the machine shows (during IIS failiure):
"The HTTP server encountered an unhandled exception while processing the ISAPI Application '
php4ts!hashpjw + 0x13
 + 0xA05E5983
'." 


We are possitive that it's the module causing the problem since when the IIS runs the CGI version everything works perfectly (except from the "header" function, wich we require). 

The module is not installed as a filter, only as an ISAPI application. 

would be thankfull for anny help!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-15 08:35 UTC] phildriscoll@php.net
As it says in the PHP installation notes, the ISAPI module 
is not stable. When it goes wrong it can bring down the 
whole of IIS.

Your best bet is to either use the cgi version which is 
rock solid, though with a slight performance penalty, or 
if you can, switch from IIS to Apache and run the Apache 
Module.

 [2002-06-18 18:45 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 18:03:43 2023 UTC