php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12753 stristr Bug
Submitted: 2001-08-15 01:38 UTC Modified: 2001-10-20 06:06 UTC
From: Darwin at MusePlay dot com Assigned:
Status: Closed Package: Strings related
PHP Version: 4.0.6 OS: Linux 7.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: Darwin at MusePlay dot com
New email:
PHP Version: OS:

 

 [2001-08-15 01:38 UTC] Darwin at MusePlay dot com
There appears to be a bug in the stristr function.  If $haystack contains a string that includes "<P>" and $needle is "<p>", then this function fails.  However, if we keep $haystack the same and change $needle to "<P>", the function works.  This is very odd, since I have only observed this behavior in this particular instance, no where else...

Take care,
Darwin

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-20 06:06 UTC] sander@php.net
Unable to reproduce with 4.1.0RC1.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 23 17:01:23 2021 UTC