php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12746 CGI Bad Header Error - Random
Submitted: 2001-08-14 19:43 UTC Modified: 2002-06-03 12:15 UTC
Votes:5
Avg. Score:4.8 ± 0.4
Reproduced:5 of 5 (100.0%)
Same Version:2 (40.0%)
Same OS:5 (100.0%)
From: David dot Carter at ExpressComputerSupply dot Com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.6 OS: Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: David dot Carter at ExpressComputerSupply dot Com
New email:
PHP Version: OS:

 

 [2001-08-14 19:43 UTC] David dot Carter at ExpressComputerSupply dot Com
Random Error:

CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

System: Dell Poweredge 350 w/1GB Ram, Win2K, MS SQL 2000

Basically the page is blank, like there was some error that is not being reported properly.  There is no output from the page at all, just that error message.  When the page is refreshed, page is fine, but sooner or later the error comes back requiring a refresh.

Our pages are pretty complex, so a snippet is not going to be feasible.  We run a page with 9 frames on it for our intranet. Sometimes all 9 frames will be displayed correctly, sometime as many as 3 frames with get that error.

Frames are thing like Customer Info, Customer Order, Customer Aging, Inventory levels, Item Sold History, etc, etc, etc.

I have seen this reported numerous times on this system, but the last one is 4.0.3p11 or something like that ... this is 4.0.6 ... if there is anything you wish me to test or to look at, let me know.

I have looked at the IIS logs and nothing seems to stand out persay. I have been counting on using PHP on NT and never dreamed this sort of thing would happen.  Been using PHP since it was PHP/FI :-)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-14 19:44 UTC] David dot Carter at ExpressComputerSupply dot Com
Sorry, the message looks like the "bad header" returns the "system: " line ... there is nothing after the bad header ... zilch ... I was just reporting what my system was and that has nothting to do with the header ... sorry that was unclear.
 [2002-06-03 12:15 UTC] mfischer@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 12:05:49 2023 UTC