php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12736 ? just found :)
Submitted: 2001-08-14 03:46 UTC Modified: 2002-06-02 19:22 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: ice_croft at mail dot ru Assigned:
Status: Not a bug Package: COM related
PHP Version: 4.0.6 OS: windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ice_croft at mail dot ru
New email:
PHP Version: OS:

 

 [2001-08-14 03:46 UTC] ice_croft at mail dot ru
hi there. :)

c:\apache\htdocs\bars.php

<?php
$ob = new COM ("pfAX.obj5");
$rs = $ob->getData(); // this method returns adodb recordset
session_register("rs"); // track_vars and 
                       // register_globals are on
?>

c:\apache\htdocs\rs.php

<?php
$num_columns = $rs->Fields->Count(); //trying to call to
                                     //the recordset
?>

So, when I open rs.php, php.exe crashes with (in russian:):

????????? PHP ??????? ???? ??? ????????? ? ???????? ?????? 
? ?????? PHP4TS.DLL ?? ?????? 0167:1008519b.
????????:
EAX=00000000 CS=0167 EIP=1008519b EFLGS=00010246
EBX=007a5750 SS=016f ESP=0063f810 EBP=0065984c
ECX=ffffffff DS=016f ESI=00000000 FS=196f
EDX=00000000 ES=016f EDI=007a6e80 GS=0000
????? ?? ?????? CS:EIP:
8b 4e 08 51 57 e8 9b ef ff ff 8b 5c 24 2c 66 c7 
?????????? ?????:
00000001 007a541c 0000000c 00000001 0065983c 00761040 006597fc 007a57c8 100b2879 00000000 007a5ae0 007a5750 00000001 00761040 0065984c 00000000 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-14 03:51 UTC] ice_croft at mail dot ru
hi there. :)

c:\apache\htdocs\bars.php

<?php
$ob = new COM ("pfAX.obj5");
$rs = $ob->getData(); // this method returns adodb recordset
session_register("rs"); // track_vars and 
                       // register_globals are on
?>

c:\apache\htdocs\rs.php

<?php
$num_columns = $rs->Fields->Count(); //trying to call to
                                     //the recordset
?>

So, when I open rs.php, php.exe crashes with (in russian:):

????????? PHP ??????? ???? ??? ????????? ? ???????? ?????? 
? ?????? PHP4TS.DLL ?? ?????? 0167:1008519b.
????????:
EAX=00000000 CS=0167 EIP=1008519b EFLGS=00010246
EBX=007a5750 SS=016f ESP=0063f810 EBP=0065984c
ECX=ffffffff DS=016f ESI=00000000 FS=196f
EDX=00000000 ES=016f EDI=007a6e80 GS=0000
????? ?? ?????? CS:EIP:
8b 4e 08 51 57 e8 9b ef ff ff 8b 5c 24 2c 66 c7 
?????????? ?????:
00000001 007a541c 0000000c 00000001 0065983c 00761040 006597fc 007a57c8 100b2879 00000000
007a5ae0 007a5750 00000001 00761040 0065984c 00000000 
 [2001-08-14 03:55 UTC] derick@php.net
Not a bug... you can't use results (resources) on a next page like this.

Ask on the php-general@lists.php.net for more information.

Derick
 [2001-08-28 04:24 UTC] sander@php.net
It is a bug: it shouldn't crash! Changed to reproducible crash.
 [2002-06-02 16:27 UTC] k.schroeder@php.net
Do you have the same problems with PHP 4.2.1?

Regards, Kai
 [2002-06-02 19:22 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Aug 16 10:05:45 2022 UTC