php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12690 array_unique under windows does not work as it does under linux
Submitted: 2001-08-10 10:31 UTC Modified: 2001-09-14 19:40 UTC
From: colin at nexus dot carleton dot ca Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 4.0.6 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
43 + 33 = ?
Subscribe to this entry?

 
 [2001-08-10 10:31 UTC] colin at nexus dot carleton dot ca
in linux, the following array would be UNCHANGED after being put through array_unique.  But, in windows you'll see below, the it doesn't seem to go deeper into the value of each array element to check if they are the same or different.

the following are the results from using array_unique on wnidows 2000
BEFORE

Array
(
    [0] => Array
        (
            [0] => 4003
            [1] => 50140
            [2] => 1
        )

    [1] => Array
        (
            [0] => 4001
            [1] => 50140
            [2] => 1
        )

    [2] => Array
        (
            [0] => 2051
            [1] => 50200
            [2] => 1
        )

    [3] => Array
        (
            [0] => 998
            [1] => 50190
            [2] => 1
        )

)

AFTER ARRAY_UNIQUE

Array
(
    [1] => Array
        (
            [0] => 4001
            [1] => 50140
            [2] => 1
        )

)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-14 19:40 UTC] jeroen@php.net
Array_unique isn't supposed to handle multi-dimension arrays, nor objects.

See also 10658
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 09:01:26 2019 UTC