php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12653 natsort, strnatcmp NOT locale-aware !
Submitted: 2001-08-08 11:18 UTC Modified: 2002-02-26 21:42 UTC
From: joustin at plusnet dot pl Assigned:
Status: Not a bug Package: Arrays related
PHP Version: 4.0.6 OS: Red Hat Linux, Win2000 sp2
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: joustin at plusnet dot pl
New email:
PHP Version: OS:

 

 [2001-08-08 11:18 UTC] joustin at plusnet dot pl
I've found out that the "Natural Sorting Algorithm" routines used by PHP are locale-unaware, probably sorting using the default english character set for reference.

Additionally, the link to "Natural Order String Comparison page" in manual seems to be dead.

sigh :(

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-26 21:42 UTC] yohgaki@php.net
The version of PHP that this bug was reported in is too old. Please
try to reproduce this bug in the latest version of PHP (available
from http://www.php.net/downloads.php

If you are still able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Thu Jun 27 02:01:25 2019 UTC