php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12611 problems with ImageColorSet and ImageColorAt
Submitted: 2001-08-07 04:39 UTC Modified: 2001-11-10 19:19 UTC
From: m dot bergmann at sh dot cvut dot cz Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Windows
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: m dot bergmann at sh dot cvut dot cz
New email:
PHP Version: OS:

 

 [2001-08-07 04:39 UTC] m dot bergmann at sh dot cvut dot cz
It's not possible to add colors to image using this function - setting colors with index greater than ImageColorsTotal does nothing. - tested on PNG image with  10 colors. 

Also ImageColorAt crashes webserver, when used on TrueColor images.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-24 13:59 UTC] sander@php.net
Can you provide a sample script? And can you test it with the php_gd.dll from PHP-4.0.5 (http://www.php.net/downloads.php)? php_gd.dll from PHP-4.0.6 is the unstable beta-version of GD. Both problems might be caused by this.
 [2001-11-10 19:19 UTC] rasmus@php.net
The ImageColorAt() issue has been fixed in CVS and will be in 4.1.  ImageColorSet() does nothing for truecolor images, which is correct.  For indexed images, use ImageColorAllocate to allocate more entries in the palette.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Dec 07 03:05:52 2022 UTC