php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12607 new autoconf 2.52 does not work with latest CVS.
Submitted: 2001-08-06 16:42 UTC Modified: 2001-08-17 01:58 UTC
From: mochaexpress at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0CVS-2001-08-06 OS: NetBSD/Alpha 1.5W
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mochaexpress at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-08-06 16:42 UTC] mochaexpress at yahoo dot com
# uname -a
NetBSD ns01 1.5W NetBSD 1.5W (ALPHA-$Revision: 1.127.2.2 $) #5: Mon Jun 25 22:34:09 CDT 2001
tom@ns01:/usr/src/sys/arch/alpha/compile/ns01 alpha

rm config.cache 
export LIBS="-lm -lc -lintl -lX11" && \
export LDFLAGS="-Wl,-export-dynamic \
  -Wl,-R/usr/lib -L/usr/lib \
  -Wl,-R/usr/pkg/lib -L/usr/pkg/lib \
  -Wl,-R/usr/local/lib -L/usr/local/lib \
  -Wl,-R/usr/X11R6/lib -L/usr/X11R6/lib"

./configure \
--with-apxs \
--disable-pear \
--with-gd=/usr/pkg \
--with-png-dir=/usr/pkg \
--with-jpeg-dir=/usr/pkg \
--with-freetype-dir=/usr/pkg \
--with-xpm-dir=/usr/X11R6 \
--with-pgsql=/usr/local \
--with-mysql=/usr/local \
--enable-libgcc \
--with-gnu-ld \
--with-zlib \
--with-system-regex \
--with-config-file-path=/usr/local/etc \
--enable-track-vars \
--enable-force-cgi-redirect \
--enable-discard-path \
--enable-memory-limit \
--enable-sysvsem \
--enable-sysvshm \
--enable-sockets \
--with-ttf=/usr/pkg \
--enable-freetype-4bit-antialias-hack

configure status hangs at:
...
checking for gdImageColorResolve in -lgd... yes
checking for gdImageGifCtx in -lgd... no
checking whether to include GNU gettext support... no
checking for gmp support... no
checking for Hyperwave support... no
checking for ICAP support... no
checking for iconv support... no
./configure: 23508: Syntax error: redirection unexpected

config.log:
# tail -20 config.log
/home/staffs/t/tom/work/php/php4-current/php4/configure:22183: undefined reference to `gdImageGif
Ctx'
/home/staffs/t/tom/work/php/php4-current/php4/configure:22183: undefined reference to `gdImageGif
Ctx'
collect2: ld returned 1 exit status
configure: failed program was:
#line 22176 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char gdImageGifCtx();

int main() {
gdImageGifCtx()

; return 0; }
configure:22274: checking whether to include GNU gettext support
configure:22697: checking for gmp support
configure:22977: checking for Hyperwave support
configure:23146: checking for ICAP support
configure:23465: checking for iconv support

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-07 02:47 UTC] sniper@php.net
Are you sure you don't have some old GD library remains
in your system, like old .h files from previous version?

With which GD library version are you trying this with?
With which capabilities was it compiled with?

What is on line 23508 in your configure file?

(And that last configure option to enable some 'hack' does
not exist anymore.. :)

--Jani

 [2001-08-07 20:29 UTC] mochaexpress at yahoo dot com
I'm sure there isn't any old remains of previous versions of gd. I'm using gd-1.8.3. FYI, php-4.0.5 and php-4.0.6 compiles fine with my gd installation. This only happens in the current CVS.

gd was build with these features:
zlib, freetype-lib, jpeg, png, xpm

Line 23508 from configure (marked with ***):

if test "$PHP_ICONV" != "no"; then

***  for i in /usr /usr/local $PHP_ICONV; do
    test -r $i/include/iconv.h && ICONV_DIR=$i
  done

  if test -z "$ICONV_DIR"; then
    { echo "configure: error: Please reinstall the iconv library." 1>&2; exit 1; }
  fi

<<<<<<< config.m4


 [2001-08-07 21:07 UTC] sniper@php.net
What is your default shell? ie. where does /bin/sh point?

--Jani

 [2001-08-08 00:16 UTC] mochaexpress at yahoo dot com
# echo $SHELL
/bin/sh
# ls -la /bin | grep sh
-r-xr-xr-x   1 root  wheel     611736 Jul 19 16:47 csh
-r-xr-xr-x   1 root  wheel     665872 Jul 19 16:47 ksh
-r-xr-xr-x   1 root  wheel     701576 Jul 19 16:48 sh
 [2001-08-12 18:53 UTC] sniper@php.net
reclassified.

 [2001-08-17 01:02 UTC] mochaexpress at yahoo dot com
i just deinstalled autoconf-2.52 and installed an earlier version: autoconf-2.13, but the same error about redirection persist (using php-cvs from today).

# ./cvsclean
# ./buildconf
buildconf: checking installation...
buildconf: autoconf version 2.13 (ok)
buildconf: automake version 1.4 (ok)
buildconf: libtool version 1.4a (ok)
rebuilding Makefile templates
automake: configure.in: installing `Zend/ylwrap'
rebuilding configure
rebuilding acconfig.h
rebuilding main/php_config.h.in
---
...
checking for Hyperwave support... no
checking for ICAP support... no
checking for iconv support... no
./configure: 23512: Syntax error: redirection unexpected
---
line 23512 from configure is marked with ***:

if test "$PHP_ICONV" != "no"; then

***  for i in /usr /usr/local $PHP_ICONV; do
    test -r $i/include/iconv.h && ICONV_DIR=$i
  done

  if test -z "$ICONV_DIR"; then
    { echo "configure: error: Please reinstall the iconv library." 1>&2; exit 1; }
  fi

<<<<<<< config.m4
---
therefore i can conclude that' it's not autoconf's fault. something else is happening here. could it be an error in an earlier line prior to 23512 which caused this error?
 [2001-08-17 01:10 UTC] sniper@php.net
Are you sure you don't have some cvs conflict there?
Or what is this line:

<<<<<<< config.m4 

--Jani

 [2001-08-17 01:11 UTC] mfischer@php.net
I bet that if you use libtool1.4 (no trailing character after the '4') it will work.

At least, it did for me.

- Marks
 [2001-08-17 01:13 UTC] mfischer@php.net
Oops, should have read more closely :/

But you can give it a try if it doesn't work.

- Markus
 [2001-08-17 01:23 UTC] mochaexpress at yahoo dot com
trying an ealier libtool won't help. i did that already -- all the way back to 1.3.5. i'm pretty sure i don't have any cvs conflicts. i've even tried it with a fresh cvs checkout. the line:

<<<<<<< config.m4

was in the configure script (preceeded by the other lines).

just now i moved the ./ext/iconv directory outside of ./ext and did the configure again. it WORKED (for the configure part anyway). i think one of the file in iconv dir is messed up.
 [2001-08-17 01:30 UTC] mfischer@php.net
Oops, should have read more closely :/

But you can give it a try if it doesn't work.

- Markus
 [2001-08-17 01:34 UTC] sniper@php.net
Obviously your cvs checkout isn't clean. 
Please use the snapshots from http://snaps.php.net/

--Jani

 [2001-08-17 01:58 UTC] mochaexpress at yahoo dot com
got the snap, ran configure with my options before.. it did pass that point but stopped at:

checking libexpat dir for Sablotron 0.50... yes
checking for SablotSetEncoding in -lsablot... yes
checking for iconv_open in -lc... no
configure: error: iconv not found
# tail config.log
#line 48473 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char iconv_open();

int main() {
iconv_open()
; return 0; }

--- 

then i applied this patch i sent in before, but it looks like it didn't make it to cvs yet:

   --- iconv/config.m4.orig        Mon Jun 25 08:42:44 2001
   +++ iconv/config.m4     Mon Jun 25 09:30:37 2001
   @@ -29,7 +29,7 @@
   
      if test -e $ICONV_DIR/lib/libconv.a -o -e $ICONV_DIR/lib/libiconv.so ; then
        PHP_ADD_LIBRARY_WITH_PATH(iconv, $ICONV_DIR/lib, ICONV_SHARED_LIBADD)
   -    AC_CHECK_LIB(iconv, iconv_open, AC_DEFINE(HAVE_ICONV, 1, [ ]))
   +    AC_CHECK_LIB(iconv, libiconv_open, AC_DEFINE(HAVE_LIBICONV, 1, [ ]))
      else
        AC_CHECK_LIB(c, iconv_open, AC_DEFINE(HAVE_ICONV, 1, [ ]))
      fi
   
   --- sablot/config.m4.orig       Mon Jun 25 10:10:56 2001
   +++ sablot/config.m4    Mon Jun 25 10:10:22 2001
   @@ -49,7 +49,11 @@
      fi
   
      found_iconv=no
   -  AC_CHECK_LIB(c, iconv_open, found_iconv=yes)
   +  if test -e $ICONV_DIR/lib/libconv.a -o -e $ICONV_DIR/lib/libiconv.so ; then
   +    AC_CHECK_LIB(iconv, libiconv_open, found_iconv=yes)
   +  else
   +    AC_CHECK_LIB(c, iconv_open, found_iconv=yes)
   +  fi
      if test "$found_iconv" = "no"; then
        if test "$PHP_ICONV" = "no"; then
          for i in /usr /usr/local; do
   
   --- xslt/config.m4.orig Mon Jun 25 10:11:57 2001
   +++ xslt/config.m4      Mon Jun 25 10:13:13 2001
   @@ -65,7 +65,11 @@
        fi
   
        found_iconv=no
   -    AC_CHECK_LIB(c, iconv_open, found_iconv=yes)
   +    if test -e $ICONV_DIR/lib/libconv.a -o -e $ICONV_DIR/lib/libiconv.so ; then
   +      AC_CHECK_LIB(iconv, libiconv_open, found_iconv=yes)
   +    else
   +      AC_CHECK_LIB(c, iconv_open, found_iconv=yes)
   +    fi
        if test "$found_iconv" = "no"; then
          if test "$PHP_ICONV" = "no"; then
            for i in /usr /usr/local; do

   --- iconv/iconv.c.orig  Mon Jun 25 11:14:39 2001
   +++ iconv/iconv.c       Mon Jun 25 11:08:40 2001
   @@ -25,7 +25,7 @@
   
    #include "php.h"
   
   -#if HAVE_ICONV
   +#if HAVE_ICONV || HAVE_LIBICONV
   
    #include <iconv.h>

----
then ran ./buildconf followed by configure... 
configure finished without any further problems.
gmake went pretty smooth as well. it almost even finished 'til this:

/bin/sh /home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235/libtool --silent --mode=l
ink gcc -I. -I/home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235/ -I/home/staffs/t/t
om/work/php/php4-current/snap/php4-200108162235/main -I/home/staffs/t/tom/work/php/php4-current/s
nap/php4-200108162235 -I/home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235/Zend -I/u
sr/local/include/freetype2/freetype -I/usr/pkg/include -I/usr/local/include/mysql -I/usr/local/in
clude -I/usr/local/install/Sablot-0.52/include  -I/usr/pkg/include -I/home/staffs/t/tom/work/php/
php4-current/snap/php4-200108162235/TSRM -g -O2  -Wl,-export-dynamic   -Wl,-R/usr/lib -L/usr/lib
  -Wl,-R/usr/pkg/lib -L/usr/pkg/lib   -Wl,-R/usr/local/lib -L/usr/local/lib   -Wl,-R/usr/X11R6/li
b -L/usr/X11R6/lib -o php -export-dynamic        stub.lo libphp4.la
./.libs/libphp4.a(gd.o): In function `php_imagettftext_common':
/home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235/ext/gd/gd.c:2748: undefined refer
ence to `gdImageStringFT'
/home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235/ext/gd/gd.c:2748: undefined refer
ence to `gdImageStringFT'
collect2: ld returned 1 exit status
gmake[1]: *** [php] Error 1
gmake[1]: Leaving directory `/home/staffs/t/tom/work/php/php4-current/snap/php4-200108162235'
gmake: *** [all-recursive] Error 1

--- but i think that is a diff problem altoghether. you probably could close this now. we can open a new one for gd :)




 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 04:01:23 2020 UTC