php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12595 $argv passing
Submitted: 2001-08-06 09:00 UTC Modified: 2010-12-22 16:54 UTC
From: sorgo at alternet dot sk Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 4.0.6 OS: win2k (prob. all win's)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sorgo at alternet dot sk
New email:
PHP Version: OS:

 

 [2001-08-06 09:00 UTC] sorgo at alternet dot sk
When installing php on win32 it creates a registry record at "My Computer\HKEY_CLASSES_ROOT\Applications\" named php.exe

the problem is that the value of "My Computer\HKEY_CLASSES_ROOT\Applications\php.exe\shell\open\command\" is default 'C:\php\php.exe "%1"' it means it only passes to php.exe the first argument = the name of the file and it do NOT pass any other arguments.

The solution is (maybe can be in a newer version of win32 php) to set the value to 'C:\php\php.exe -q "%1" %2 %3 %4 %5 %6 %7 %8 %9'

(maybe without the -q argument)

Sorgo

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-18 06:37 UTC] sorgo at alternet dot sk
with 'C:\php\php.exe -q "%1" %2 %3 %4 %5 %6 %7 %8 %9' set the command line arguments cannot contain spaces, it should be rather 

'C:\php\php.exe -q "%1" "%2" "%3" "%4" "%5" "%6" "%7" "%8" "%9"' to allow the possibility to escape arguments containing spaces into "'s
 [2010-12-17 12:30 UTC] jani@php.net
-Package: Feature/Change Request +Package: Windows Installer
 [2010-12-22 16:53 UTC] jmertic@php.net
Automatic comment from SVN on behalf of jmertic
Revision: http://svn.php.net/viewvc/?view=revision&revision=306573
Log: Bug 12595 - Fix problem where only the first argument to the php script is passed; now support up to 9 arguments.
 [2010-12-22 16:54 UTC] jmertic@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: jmertic
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 12:03:34 2021 UTC