php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12555 imap_body on empty messages causes seg fault
Submitted: 2001-08-03 12:08 UTC Modified: 2002-06-24 23:01 UTC
From: jon at cmoo dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jon at cmoo dot com
New email:
PHP Version: OS:

 

 [2001-08-03 12:08 UTC] jon at cmoo dot com
After opening an imap connection, calling imap_body for a message which is has an empty body will cause the apache server to seg fault (11). This caused several problems as on some of our accounts the first message was empty (for other reasons) and so any php imap client would fail immediately on loading. We have fixed this by testing for message size - but the imap_body code should probably spot this.

Thanks,

Jon.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-06 07:51 UTC] sniper@php.net
I can not reproduce this with PHP 4.0.6. 
With which c-client version is your PHP linked with?

--Jani

 [2001-08-06 08:42 UTC] jon at cmoo dot com
The version linked to from the documentation pages (4.7 i believe) - though I have tried others (regressing back). I am minded that this 'could' be a very isolated error caused by the imap mailbox containing 0 byte files (which clearly would not happen very often). If this is the case, contact me for details of how to access an account with these 0byte files.

Thanks,
 [2002-06-24 23:01 UTC] kalowsky@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 24 04:03:36 2021 UTC