php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12441 print line function?
Submitted: 2001-07-27 21:10 UTC Modified: 2001-08-12 15:18 UTC
From: yohgaki at hotmail dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.6 OS:
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: yohgaki at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-07-27 21:10 UTC] yohgaki at hotmail dot com
How about to have a print function that appends newline?

println('some string'); 
// Append "\n","\r" or "\r\n" depends on setting

If newline character(s) could be specified by php.ini entry, script would be more portable.

I think it's much cleaner than have constant (or variable) like
print('some string'.NEWLINE);

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-12 15:18 UTC] sebastian@php.net
Duplicate of Bug #12428.

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Dec 11 19:01:25 2019 UTC