php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12402 Including GD support shuts down PWS
Submitted: 2001-07-26 10:29 UTC Modified: 2001-12-19 08:47 UTC
From: avillaci at ceibo dot fiec dot espol dot edu dot ec Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Windows 98 SE
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: avillaci at ceibo dot fiec dot espol dot edu dot ec
New email:
PHP Version: OS:

 

 [2001-07-26 10:29 UTC] avillaci at ceibo dot fiec dot espol dot edu dot ec
I downloaded PHP 4.0.6 for Win32, full version (ZIP
package, binary distribution), and installed it on PWS 4.0
for ISAPI invocation.

Everything works fine except for GD library support: when
I include the library in PHP.INI, and then an attempt is
made to execute *any* PHP script under PWS (even <? phpinfo(); ?>), the server process shuts down silently. No error
log, no message box, no GPF fault display, not even a Blue 
Screen of Death. The server process (INETINFO.EXE) just
disappears from the list of active processes, and any 
further request for HTML pages of any kind (not only PHP)
fails with a "Server not found" error. 

I tried to execute PHP from the command line in order to
check the problem, and the resulting HTML output shows
a complaint about GD support not enabled on the build.
Please note that this is a different message from a
"function not recognized error" (I tried with and without
GD invocation just to be sure). 

Could you please suggest what might be wrong with PHP or
PWS? Or how to make PHP accept GD as a library (I thought
dynamic DLLs dispensed with the need to recompile PHP).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-28 08:38 UTC] sander@php.net
PHP 4.0.6 uses GD 2.0 which is still beta. That might be the cause of this. Can you try the PHP 4.1.0 when it's out (it will be released in a few days)?
 [2001-12-19 08:46 UTC] sander@php.net
No feedback. Closing.
 [2001-12-19 08:47 UTC] derick@php.net
Also note that GD is _not_ thread safe, and may not work in threaded servers, like PWS and IIS.

Derick
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 15:05:53 2022 UTC