php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12317 Mailing list is bouncing back my email.
Submitted: 2001-07-23 09:20 UTC Modified: 2001-07-27 12:18 UTC
From: jeremy at nirvani dot net Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.6 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jeremy at nirvani dot net
New email:
PHP Version: OS:

 

 [2001-07-23 09:20 UTC] jeremy at nirvani dot net
A copy of the email:

The error is saying that the email server does not accept messages shorter than 2 bytes.

This happens every time I try and post to any of the lists.

I've already contacted pair.com and they said that they can not help because they do not run the php listservs.

Thanks,
Jeremy

####################################


From jeremy@nirvani.net Mon Jul 23 15:07:06 2001 +0200
Status: R
X-Status:
X-Keywords:
Return-Path: <>
X-Flags: 0000
Delivered-To: GMX delivery to what_is_the@gmx.net
Received: from rogue [127.0.0.1]
        by localhost with POP3 (fetchmail-5.8.12)
        for jeremy@localhost (single-drop); Mon, 23 Jul 2001 15:07:06 +0200 ()
Received: (qmail 31969 invoked by uid 0); 23 Jul 2001 13:03:45 -0000
Received: from pb1.pair.com (216.92.131.4)
  by mx0.gmx.net (mx07) with SMTP; 23 Jul 2001 13:03:45 -0000
Received: (qmail 43903 invoked for bounce); 23 Jul 2001 13:03:55 -0000
Date: 23 Jul 2001 13:03:55 -0000
From: MAILER-DAEMON@pb1.pair.com
To: what_is_the@gmx.net
Subject: failure notice
Message-ID: <20010723130345.31975gmx1@mx07.gmx.net>

Hi. This is the qmail-send program at pb1.pair.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<php-general@lists.php.net>:
ezmlm-reject: fatal: Sorry, I don't accept messages shorter than 2 bytes (#5.2.3)

--- Below this line is a copy of the message.

Return-Path: <what_is_the@gmx.net>
Received: (qmail 43867 invoked from network); 23 Jul 2001 13:03:37 -0000
Received: from unknown (HELO mail.gmx.net) (194.221.183.20)
  by pb1.pair.com with SMTP; 23 Jul 2001 13:03:37 -0000
Received: (qmail 11653 invoked by uid 0); 23 Jul 2001 13:03:20 -0000
Received: from unknown (HELO nirvani.net) (217.199.1.157)
  by mail.gmx.net (mp001-rz3) with SMTP; 23 Jul 2001 13:03:20 -0000
Received: (Initial drop from localhost [127.0.0.1] by mobile mail 1.0.0. www.nirvani.net/software/); 23 Jul 2001 13:04:15 -0000
Date: Mon, 23 Jul 2001 03:02:20 +0200 (WEDT)
From: jeremy brand <jeremy@nirvani.net>
X-Sender:  <jeremy@rogue>
To: Jeremy <nospam@email.com>
cc:  <php-general@lists.php.net>
Subject: Re: [PHP] bitwise AND is acting strange
In-Reply-To: <20010723003132.16191.qmail@pb1.pair.com>
Message-ID: <Pine.CYG.4.30.0107230258260.832-100000@rogue>
X-Originally-From: <jeremy@nirvani.net>
X-Organization: http://www.smackdown.com/
X-finger: Not available
X-Yo-Mama: Whatchew talkin' 'bout Willis?
X-face: Not available
X-security: setec astronomy
X-OS: Linux
X-animal: Penguin
X-suck-o-meter: Microsoft
X-homepage: http://www.jeremybrand.com/Jeremy/Brand/Jeremy_Brand.html
X-pgp-key: GnuPG Ver. 1 key available at http://www.nirvani.net/pgp-key
X-GnuPG-Fingerprint: 7C1F 8AE1 9EE8 62D5 A68C  531A F36B AE2B C0E9 3420
X-Geekcode: http://www.nirvani.net/geekcode
X-Mailer: Pine (4.30) and proud!
MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII

Hi Jeremy

I do all kinds of bit mask suff in my code. I've been doing it back since
version 3 _and_ ever since I've been doing it, I've never once had a
problem.

Your example:
(2 & 10)
works for me (my example)

  print (2 & 10). "\n";

It prints 2.

Most likely, you are missing something else in your code.  You might want
to double check something.

You might want to _echo_ your SQL queries out.  That is the most probable
place that something is haywire.

So, to answer your question (am I missing something)?. No, you are not.
:)

Hope this helps.
Jeremy

--
Jeremy Brand :: Sr. Software Engineer :: +393485323988 :: jeremy@nirvani.net
http://www.JeremyBrand.com/Jeremy/Brand/Jeremy_Brand.html for more
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    "LINUX is obsolete"  -- Andy Tanenbaum, January 29th, 1992
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  Get your own Free, Private email at http://www.smackdown.com/

On Sun, 22 Jul 2001, the following spilled from the mind of Jeremy:

> Date: Sun, 22 Jul 2001 19:32:53 -0700
> From: Jeremy <nospam@email.com>
> To: php-general@lists.php.net
> Subject: [PHP] bitwise AND is acting strange
>
> The users on my website all have an "access" number that is used to give
> them access to different parts of the site. Each bit represents a different
> part of the site. So, if a user has an access of 10, which is 1010 in
> binary, they have access to the parts of the site that are represented by
> the second and fourth bit. You know, standard bit masking stuff.
>
> So the part of the site that is represented by the second bit has a value of
> 2 (0010), and the part that is represented by the fourth bit has a value of
> 8 (1000)
>
> BUT, for some reason when I do (2 & 10) its giving me a result of zero, when
> I believe it should be doing (0010 & 1010) and giving me an answer of 0010
> which is 2 in decimal.
>
> With users with an access other than 10, say 9, or 8, or 7, it seems to
> behave normally. What is going on? Is it treating the 10 as a binary 2?
> These access values are stored in a mysql table as a standard INT, and they
> are not UNSIGNED or BINARY.
>
> Am I missing something?
>
> Jeremy
>
>
>
>
>
>
>
>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-27 12:18 UTC] sniper@php.net
forwarded to group@php.net which handles these problems.

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Sep 28 06:05:53 2022 UTC