php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12285 Problem in header parameter
Submitted: 2001-07-20 10:37 UTC Modified: 2002-08-23 21:30 UTC
From: lazaris at ceid dot upatras dot gr Assigned:
Status: Closed Package: Mail related
PHP Version: 4.0.6 OS: Windows 2000
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: lazaris at ceid dot upatras dot gr
New email:
PHP Version: OS:

 

 [2001-07-20 10:37 UTC] lazaris at ceid dot upatras dot gr
I am using PHP 4.0.6 (the same applies with version 4.0.5) on Windows 2000. I have written a page where someone can send MIME mail including multiple attachments. The attachments go into the header parameter of the mail() function. The bug I'm reporting is that when the attached part(s) are more than 2KB in size, the mail() function crashes and together PHP.exe. I believe there must be some unreasonable limitation in the size of the header parameter. I don't know if this problem exists in Unix environments, but I know at least another developer who has reported the same problem on the Windows platform.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-09-01 14:05 UTC] sander@php.net
Duplicate of 11165
 [2002-08-23 21:30 UTC] sniper@php.net
Try this snapshot:

http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

Reopen if problem persists.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Aug 05 22:01:24 2021 UTC